Videokarma.org

Go Back   Videokarma.org TV - Video - Vintage Television & Radio Forums > Recorded Video

We appreciate your help

in keeping this site going.
Reply
 
Thread Tools Display Modes
  #1  
Old 02-11-2018, 09:38 PM
Adam's Avatar
Adam Adam is offline
VideoKarma Member
 
Join Date: Oct 2005
Location: Madison, WI
Posts: 2,207
1979 rca vdt600

At first, it would rewind and fast forward, but not play. I replaced belts, and now it plays tapes. I got a belt kit that said it was for an RCA VDT600 (and others), but the smaller of the 2 belts that drives the counter was way too large. (and there were multiple duplicates of two of the other belts - not that that was a problem) So with that 1 original belt still slipping in there, the counter won't run.

The other problem it has is that the clock is barely lit up. At first I thought it was completely dead, but looking closely I can just see it on. And I tried setting it, and saw that it functions otherwise. Much like in the other thread I just started about the Zenith clock radio, is this likely to be the display itself or something else? And again I'm going to have to dig up a schematic if I have to start poking around.
__________________
The quality goes in, before the cat goes on!!
Reply With Quote
  #2  
Old 02-12-2018, 08:11 AM
kf4rca kf4rca is offline
VideoKarma Member
 
Join Date: Feb 2015
Posts: 252
Most likely caps in the inverter section for the vaccuum flourescent display. MCM Electronics used to sell kits to rebuild these.
__________________
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:57 PM.



Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
ęCopyright 2012 VideoKarma.org, All rights reserved.