Videokarma.org

Go Back   Videokarma.org TV - Video - Vintage Television & Radio Forums > Transistor Radio

We appreciate your help

in keeping this site going.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 11-17-2018, 04:05 AM
radiodayz's Avatar
radiodayz radiodayz is offline
radiodayz
 
Join Date: May 2010
Location: Seattle WA USA
Posts: 112
Zenith Royal 755 battery leak

I'm a bit embarrassed to admit this in a public forum, but I need some help...
I have a Zenith Royal 755 large AM portable that I've had for a year or two. It always worked fine, but I noticed a few days ago that the batteries were getting weak. This morning, I put six fresh C cells in it, turned it on, nothing. I had to leave for work, but I resolved to check on it later. When I returned a few hours later, the battery tube was warm to the touch and fluid was sizzling and oozing out. I quickly removed the batteries. I probably had installed them with the wrong orientation, I guess; they're supposed to be loaded with four facing one direction and two the other, but I must have screwed up somehow. Anyway, what should I do know? Is there any hope it can be restored to operating condition? I don't think any critical components were damaged.
__________________
I have one of those around here, somewhere
Reply With Quote
 


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:43 PM.



Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
ęCopyright 2012 VideoKarma.org, All rights reserved.